# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\\\/\\\\\.\\\\]"
test_str = ("$$\\left[ x=\\left({{11}\\over{2}}+{{\\sqrt{3271}}\\over{2\\,3^{{{3}\\over{2\n"
" }}}}}\\right)^{{{1}\\over{3}}}\\,\\left(-{{1}\\over{2}}-{{\\sqrt{3}\\,i\n"
" }\\over{2}}\\right)-{{{{\\sqrt{3}\\,i}\\over{2}}-{{1}\\over{2}}}\\over{3\\,\n"
" \\left({{11}\\over{2}}+{{\\sqrt{3271}}\\over{2\\,3^{{{3}\\over{2}}}}}\n"
" \\right)^{{{1}\\over{3}}}}} , x=\\left({{11}\\over{2}}+{{\\sqrt{3271}\n"
" }\\over{2\\,3^{{{3}\\over{2}}}}}\\right)^{{{1}\\over{3}}}\\,\\left({{\\sqrt{\n"
" 3}\\,i}\\over{2}}-{{1}\\over{2}}\\right)-{{-{{1}\\over{2}}-{{\\sqrt{3}\\,i\n"
" }\\over{2}}}\\over{3\\,\\left({{11}\\over{2}}+{{\\sqrt{3271}}\\over{2\\,3^{\n"
" {{3}\\over{2}}}}}\\right)^{{{1}\\over{3}}}}} , x=\\left({{11}\\over{2}}+\n"
" {{\\sqrt{3271}}\\over{2\\,3^{{{3}\\over{2}}}}}\\right)^{{{1}\\over{3}}}-{{\n"
" 1}\\over{3\\,\\left({{11}\\over{2}}+{{\\sqrt{3271}}\\over{2\\,3^{{{3}\\over{\n"
" 2}}}}}\\right)^{{{1}\\over{3}}}}} \\right] $$")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.