import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\\\\\/\\\\\\\\\\.\\\\\\\\]";
final String string = "$$\\left[ x=\\left({{11}\\over{2}}+{{\\sqrt{3271}}\\over{2\\,3^{{{3}\\over{2\n"
+ " }}}}}\\right)^{{{1}\\over{3}}}\\,\\left(-{{1}\\over{2}}-{{\\sqrt{3}\\,i\n"
+ " }\\over{2}}\\right)-{{{{\\sqrt{3}\\,i}\\over{2}}-{{1}\\over{2}}}\\over{3\\,\n"
+ " \\left({{11}\\over{2}}+{{\\sqrt{3271}}\\over{2\\,3^{{{3}\\over{2}}}}}\n"
+ " \\right)^{{{1}\\over{3}}}}} , x=\\left({{11}\\over{2}}+{{\\sqrt{3271}\n"
+ " }\\over{2\\,3^{{{3}\\over{2}}}}}\\right)^{{{1}\\over{3}}}\\,\\left({{\\sqrt{\n"
+ " 3}\\,i}\\over{2}}-{{1}\\over{2}}\\right)-{{-{{1}\\over{2}}-{{\\sqrt{3}\\,i\n"
+ " }\\over{2}}}\\over{3\\,\\left({{11}\\over{2}}+{{\\sqrt{3271}}\\over{2\\,3^{\n"
+ " {{3}\\over{2}}}}}\\right)^{{{1}\\over{3}}}}} , x=\\left({{11}\\over{2}}+\n"
+ " {{\\sqrt{3271}}\\over{2\\,3^{{{3}\\over{2}}}}}\\right)^{{{1}\\over{3}}}-{{\n"
+ " 1}\\over{3\\,\\left({{11}\\over{2}}+{{\\sqrt{3271}}\\over{2\\,3^{{{3}\\over{\n"
+ " 2}}}}}\\right)^{{{1}\\over{3}}}}} \\right] $$";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}