package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\\\/\\\\\.\\\\]`)
var str = `$$\left[ x=\left({{11}\over{2}}+{{\sqrt{3271}}\over{2\,3^{{{3}\over{2
}}}}}\right)^{{{1}\over{3}}}\,\left(-{{1}\over{2}}-{{\sqrt{3}\,i
}\over{2}}\right)-{{{{\sqrt{3}\,i}\over{2}}-{{1}\over{2}}}\over{3\,
\left({{11}\over{2}}+{{\sqrt{3271}}\over{2\,3^{{{3}\over{2}}}}}
\right)^{{{1}\over{3}}}}} , x=\left({{11}\over{2}}+{{\sqrt{3271}
}\over{2\,3^{{{3}\over{2}}}}}\right)^{{{1}\over{3}}}\,\left({{\sqrt{
3}\,i}\over{2}}-{{1}\over{2}}\right)-{{-{{1}\over{2}}-{{\sqrt{3}\,i
}\over{2}}}\over{3\,\left({{11}\over{2}}+{{\sqrt{3271}}\over{2\,3^{
{{3}\over{2}}}}}\right)^{{{1}\over{3}}}}} , x=\left({{11}\over{2}}+
{{\sqrt{3271}}\over{2\,3^{{{3}\over{2}}}}}\right)^{{{1}\over{3}}}-{{
1}\over{3\,\left({{11}\over{2}}+{{\sqrt{3271}}\over{2\,3^{{{3}\over{
2}}}}}\right)^{{{1}\over{3}}}}} \right] $$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}