use strict;
my $str = '$$\\left[ x=\\left({{11}\\over{2}}+{{\\sqrt{3271}}\\over{2\\,3^{{{3}\\over{2
}}}}}\\right)^{{{1}\\over{3}}}\\,\\left(-{{1}\\over{2}}-{{\\sqrt{3}\\,i
}\\over{2}}\\right)-{{{{\\sqrt{3}\\,i}\\over{2}}-{{1}\\over{2}}}\\over{3\\,
\\left({{11}\\over{2}}+{{\\sqrt{3271}}\\over{2\\,3^{{{3}\\over{2}}}}}
\\right)^{{{1}\\over{3}}}}} , x=\\left({{11}\\over{2}}+{{\\sqrt{3271}
}\\over{2\\,3^{{{3}\\over{2}}}}}\\right)^{{{1}\\over{3}}}\\,\\left({{\\sqrt{
3}\\,i}\\over{2}}-{{1}\\over{2}}\\right)-{{-{{1}\\over{2}}-{{\\sqrt{3}\\,i
}\\over{2}}}\\over{3\\,\\left({{11}\\over{2}}+{{\\sqrt{3271}}\\over{2\\,3^{
{{3}\\over{2}}}}}\\right)^{{{1}\\over{3}}}}} , x=\\left({{11}\\over{2}}+
{{\\sqrt{3271}}\\over{2\\,3^{{{3}\\over{2}}}}}\\right)^{{{1}\\over{3}}}-{{
1}\\over{3\\,\\left({{11}\\over{2}}+{{\\sqrt{3271}}\\over{2\\,3^{{{3}\\over{
2}}}}}\\right)^{{{1}\\over{3}}}}} \\right] $$';
my $regex = qr/[\\\/\\\\\.\\\\]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}