$re = '/[\\\\\/\\\\\\\\\.\\\\\\\\]/';
$str = '$$\\left[ x=\\left({{11}\\over{2}}+{{\\sqrt{3271}}\\over{2\\,3^{{{3}\\over{2
}}}}}\\right)^{{{1}\\over{3}}}\\,\\left(-{{1}\\over{2}}-{{\\sqrt{3}\\,i
}\\over{2}}\\right)-{{{{\\sqrt{3}\\,i}\\over{2}}-{{1}\\over{2}}}\\over{3\\,
\\left({{11}\\over{2}}+{{\\sqrt{3271}}\\over{2\\,3^{{{3}\\over{2}}}}}
\\right)^{{{1}\\over{3}}}}} , x=\\left({{11}\\over{2}}+{{\\sqrt{3271}
}\\over{2\\,3^{{{3}\\over{2}}}}}\\right)^{{{1}\\over{3}}}\\,\\left({{\\sqrt{
3}\\,i}\\over{2}}-{{1}\\over{2}}\\right)-{{-{{1}\\over{2}}-{{\\sqrt{3}\\,i
}\\over{2}}}\\over{3\\,\\left({{11}\\over{2}}+{{\\sqrt{3271}}\\over{2\\,3^{
{{3}\\over{2}}}}}\\right)^{{{1}\\over{3}}}}} , x=\\left({{11}\\over{2}}+
{{\\sqrt{3271}}\\over{2\\,3^{{{3}\\over{2}}}}}\\right)^{{{1}\\over{3}}}-{{
1}\\over{3\\,\\left({{11}\\over{2}}+{{\\sqrt{3271}}\\over{2\\,3^{{{3}\\over{
2}}}}}\\right)^{{{1}\\over{3}}}}} \\right] $$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);