using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([0-2]|3[0-1]|32.0.0.([0-1][0-6]|170))";
string input = @"32.0.0.142
32.0.0.171
32.0.0.156
31.
29
32
30.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}