// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([0-2]|3[0-1]|32.0.0.([0-1][0-6]|170))").unwrap();
let string = "32.0.0.142
32.0.0.171
32.0.0.156
31.
29
32
30.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}