re = /^([0-2]|3[0-1]|32.0.0.([0-1][0-6]|170))/m
str = '32.0.0.142
32.0.0.171
32.0.0.156
31.
29
32
30.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end