import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-2]|3[0-1]|32.0.0.([0-1][0-6]|170))";
final String string = "32.0.0.142\n"
+ "32.0.0.171\n"
+ "32.0.0.156\n"
+ "31.\n"
+ "29\n"
+ "32\n"
+ "30.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}