import re
regex = re.compile(r"^([0-2]|3[0-1]|32.0.0.([0-1][0-6]|170))", flags=re.MULTILINE)
test_str = ("32.0.0.142\n"
"32.0.0.171\n"
"32.0.0.156\n"
"31.\n"
"29\n"
"32\n"
"30.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")