package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-2]|3[0-1]|32.0.0.([0-1][0-6]|170))`)
var str = `32.0.0.142
32.0.0.171
32.0.0.156
31.
29
32
30.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}