# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?=\(\+)\()|[\s+=]|((?<=M)\))//g;t' <<< "C5H6 + O = NC4H5 + CO + H
C5H5 + H (+M)= C5H6 (+M)
C5H5 + HO2 = C5H5O(2,4) + OH
"