import Foundation
let pattern = #"((?=\(\+)\()|[\s+=]|((?<=M)\))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
C5H6 + O = NC4H5 + CO + H
C5H5 + H (+M)= C5H6 (+M)
C5H5 + HO2 = C5H5O(2,4) + OH
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)