using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?=\(\+)\()|[\s+=]|((?<=M)\))";
string substitution = @"";
string input = @"C5H6 + O = NC4H5 + CO + H
C5H5 + H (+M)= C5H6 (+M)
C5H5 + HO2 = C5H5O(2,4) + OH
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}