#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((?=\(\+)\()|[\s+=]|((?<=M)\))"
Local $sString = "C5H6 + O = NC4H5 + CO + H" & @CRLF & _
"" & @CRLF & _
"C5H5 + H (+M)= C5H6 (+M)" & @CRLF & _
"" & @CRLF & _
"C5H5 + HO2 = C5H5O(2,4) + OH" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)