const regex = new RegExp('((?=\\(\\+)\\()|[\\s+=]|((?<=M)\\))', 'g')
const str = `C5H6 + O = NC4H5 + CO + H
C5H5 + H (+M)= C5H6 (+M)
C5H5 + HO2 = C5H5O(2,4) + OH
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);