use strict;
my $str = 'C5H6 + O = NC4H5 + CO + H
C5H5 + H (+M)= C5H6 (+M)
C5H5 + HO2 = C5H5O(2,4) + OH
';
my $regex = qr/((?=\(\+)\()|[\s+=]|((?<=M)\))/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";