import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?=\\(\\+)\\()|[\\s+=]|((?<=M)\\))";
final String string = "C5H6 + O = NC4H5 + CO + H\n\n"
+ "C5H5 + H (+M)= C5H6 (+M)\n\n"
+ "C5H5 + HO2 = C5H5O(2,4) + OH\n\n\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}