# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(-?\d{1,4}, -?\d{1,4}, -?\d{1,4})//gm;t' <<< "[16:22:99] [Client thread/INFO]: lorem ipsum
[17:30:23] [Client thread/INFO]: 108, 46, 646, world
[17:30:23] [Client thread/INFO]: -1000, 39, 719, world
[17:30:23] [Client thread/INFO]: 927, 63, -1, world
[18:42:19] [Client thread/INFO]: dolor sit amet"