const regex = /(-?\d{1,4}, -?\d{1,4}, -?\d{1,4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(-?\\d{1,4}, -?\\d{1,4}, -?\\d{1,4})', 'gm')
const str = `[16:22:99] [Client thread/INFO]: lorem ipsum
[17:30:23] [Client thread/INFO]: 108, 46, 646, world
[17:30:23] [Client thread/INFO]: -1000, 39, 719, world
[17:30:23] [Client thread/INFO]: 927, 63, -1, world
[18:42:19] [Client thread/INFO]: dolor sit amet`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);