$re = '/(-?\d{1,4}, -?\d{1,4}, -?\d{1,4})/m';
$str = '[16:22:99] [Client thread/INFO]: lorem ipsum
[17:30:23] [Client thread/INFO]: 108, 46, 646, world
[17:30:23] [Client thread/INFO]: -1000, 39, 719, world
[17:30:23] [Client thread/INFO]: 927, 63, -1, world
[18:42:19] [Client thread/INFO]: dolor sit amet';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;