package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(-?\d{1,4}, -?\d{1,4}, -?\d{1,4})`)
var str = `[16:22:99] [Client thread/INFO]: lorem ipsum
[17:30:23] [Client thread/INFO]: 108, 46, 646, world
[17:30:23] [Client thread/INFO]: -1000, 39, 719, world
[17:30:23] [Client thread/INFO]: 927, 63, -1, world
[18:42:19] [Client thread/INFO]: dolor sit amet`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}