// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(-?\d{1,4}, -?\d{1,4}, -?\d{1,4})").unwrap();
let string = "[16:22:99] [Client thread/INFO]: lorem ipsum
[17:30:23] [Client thread/INFO]: 108, 46, 646, world
[17:30:23] [Client thread/INFO]: -1000, 39, 719, world
[17:30:23] [Client thread/INFO]: 927, 63, -1, world
[18:42:19] [Client thread/INFO]: dolor sit amet";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}