#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(-?\d{1,4}, -?\d{1,4}, -?\d{1,4})"
Local $sString = "[16:22:99] [Client thread/INFO]: lorem ipsum" & @CRLF & _
"[17:30:23] [Client thread/INFO]: 108, 46, 646, world" & @CRLF & _
"[17:30:23] [Client thread/INFO]: -1000, 39, 719, world" & @CRLF & _
"[17:30:23] [Client thread/INFO]: 927, 63, -1, world" & @CRLF & _
"[18:42:19] [Client thread/INFO]: dolor sit amet"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)