# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(-?\d{1,4}, -?\d{1,4}, -?\d{1,4})"
test_str = ("[16:22:99] [Client thread/INFO]: lorem ipsum\n"
"[17:30:23] [Client thread/INFO]: 108, 46, 646, world\n"
"[17:30:23] [Client thread/INFO]: -1000, 39, 719, world\n"
"[17:30:23] [Client thread/INFO]: 927, 63, -1, world\n"
"[18:42:19] [Client thread/INFO]: dolor sit amet")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.