import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(-?\\d{1,4}, -?\\d{1,4}, -?\\d{1,4})";
final String string = "[16:22:99] [Client thread/INFO]: lorem ipsum\n"
+ "[17:30:23] [Client thread/INFO]: 108, 46, 646, world\n"
+ "[17:30:23] [Client thread/INFO]: -1000, 39, 719, world\n"
+ "[17:30:23] [Client thread/INFO]: 927, 63, -1, world\n"
+ "[18:42:19] [Client thread/INFO]: dolor sit amet";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}