# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^\d{3}|(?<=^\d{3})\d{3}|\d+$)/(\1)/gm;t' <<< "1234567899
12345678
1234567
123456
12345
123
1"