use strict;
my $str = '1234567899
12345678
1234567
123456
12345
123
1';
my $regex = qr/(^\d{3}|(?<=^\d{3})\d{3}|\d+$)/mp;
my $subst = '(\\1)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";