#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^\d{3}|(?<=^\d{3})\d{3}|\d+$)"
Local $sString = "1234567899" & @CRLF & _
"12345678" & @CRLF & _
"1234567" & @CRLF & _
"123456" & @CRLF & _
"12345" & @CRLF & _
"123" & @CRLF & _
"1"
Local $sSubst = "(\1)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)