# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^\d{3}|(?<=^\d{3})\d{3}|\d+$)"
test_str = ("1234567899\n"
"12345678\n"
"1234567\n"
"123456\n"
"12345\n"
"123\n"
"1")
subst = "(\\1)"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.