using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\d{3}|(?<=^\d{3})\d{3}|\d+$)";
string substitution = @"(\1)";
string input = @"1234567899
12345678
1234567
123456
12345
123
1";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}