import Foundation
let pattern = #"(^\d{3}|(?<=^\d{3})\d{3}|\d+$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1234567899
12345678
1234567
123456
12345
123
1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"(\1)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)