import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\d{3}|(?<=^\\d{3})\\d{3}|\\d+$)";
final String string = "1234567899\n"
+ "12345678\n"
+ "1234567\n"
+ "123456\n"
+ "12345\n"
+ "123\n"
+ "1";
final String subst = "(\\1)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}