$re = '/(^\d{3}|(?<=^\d{3})\d{3}|\d+$)/m';
$str = '1234567899
12345678
1234567
123456
12345
123
1';
$subst = "(\1)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;