package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`- \(\w+\)(composeView\(.*?\))`)
var str = `- (void)composeView(...) gives func composeView(...)
+ (void)composeView(...) gives class func composeView(...)`
var substitution = "func \1"
fmt.Println(re.ReplaceAllString(str, substitution))
}