$re = '/- \(\w+\)(composeView\(.*?\))/';
$str = '- (void)composeView(...) gives func composeView(...)
+ (void)composeView(...) gives class func composeView(...)';
$subst = "func \1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;