re = /- \(\w+\)(composeView\(.*?\))/
str = '- (void)composeView(...) gives func composeView(...)
+ (void)composeView(...) gives class func composeView(...)'
subst = 'func \\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result