// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"- \(\w+\)(composeView\(.*?\))").unwrap();
let string = "- (void)composeView(...) gives func composeView(...)
+ (void)composeView(...) gives class func composeView(...)";
let substitution = "func \\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}