import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "- \\(\\w+\\)(composeView\\(.*?\\))";
final String string = "- (void)composeView(...) gives func composeView(...)\n\n"
+ "+ (void)composeView(...) gives class func composeView(...)";
final String subst = "func \\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}