const regex = /- \(\w+\)(composeView\(.*?\))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('- \\(\\w+\\)(composeView\\(.*?\\))', 'g')
const str = `- (void)composeView(...) gives func composeView(...)
+ (void)composeView(...) gives class func composeView(...)`;
const subst = `func \1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);