use strict;
my $str = '- (void)composeView(...) gives func composeView(...)
+ (void)composeView(...) gives class func composeView(...)';
my $regex = qr/- \(\w+\)(composeView\(.*?\))/p;
my $subst = 'func \\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";