# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\h*\b\p{Lu}\p{L}*\b//gmu;t' <<< "Ещё Одно слово
hello goodbye Delete Me
Another Sentence good program
hello world The End
an iPhone
Ещё Одно слово"