$re = '/\h*\b\p{Lu}\p{L}*\b/mu';
$str = 'Ещё Одно слово
hello goodbye Delete Me
Another Sentence good program
hello world The End
an iPhone
Ещё Одно слово';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;