import re
regex = re.compile(r"\h*\b\p{Lu}\p{L}*\b", flags=re.MULTILINE | re.UNICODE)
test_str = ("Ещё Одно слово\n"
"hello goodbye Delete Me\n"
"Another Sentence good program\n"
"hello world The End\n"
"an iPhone\n"
"Ещё Одно слово")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)