#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mu)\h*\b\p{Lu}\p{L}*\b"
Local $sString = "Ещё Одно слово" & @CRLF & _
"hello goodbye Delete Me" & @CRLF & _
"Another Sentence good program" & @CRLF & _
"hello world The End" & @CRLF & _
"an iPhone" & @CRLF & _
"Ещё Одно слово"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)