re = /\h*\b\p{Lu}\p{L}*\b/m
str = 'Ещё Одно слово
hello goodbye Delete Me
Another Sentence good program
hello world The End
an iPhone
Ещё Одно слово'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result