using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\h*\b\p{Lu}\p{L}*\b";
string substitution = @"";
string input = @"Ещё Одно слово
hello goodbye Delete Me
Another Sentence good program
hello world The End
an iPhone
Ещё Одно слово";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}