// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)\h*\b\p{Lu}\p{L}*\b").unwrap();
let string = "Ещё Одно слово
hello goodbye Delete Me
Another Sentence good program
hello world The End
an iPhone
Ещё Одно слово";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}