package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\h*\b\p{Lu}\p{L}*\b`)
var str = `Ещё Одно слово
hello goodbye Delete Me
Another Sentence good program
hello world The End
an iPhone
Ещё Одно слово`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}