const regex = /\h*\b\p{Lu}\p{L}*\b/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\h*\\b\\p{Lu}\\p{L}*\\b', 'gmu')
const str = `Ещё Одно слово
hello goodbye Delete Me
Another Sentence good program
hello world The End
an iPhone
Ещё Одно слово`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);